global.privacy * required